Tuesday, March 23, 2010

Week's Worth of Update

I think I said I was going to update "tomorrow" two weeks ago.
Time sure passes fast when you're having fun!
Anyway, a LOT of stuff has happened, which I'll have to recount concisely.

First off, I decided that the mild warping on the plywood Z platform was not going to work. That was a really easy fix, as I just had to go find a sheet of acrylic of the right general shape, saw it squared, and lazzor away.

The same day, I got tired of the Z-stage coming off of the washers that are used to move it around.
At the risk of cracking it, I designed and installed some extra layers to hold it in place. I'm quite happy with how they turned out, actually. The result is that the platform cannot come off of the washers, they are totally locked in place. This has added some resistance, and it seems to stem from a moderately bent Z rod. I have some more M8 left over, so I think I'll replace it.

The other thing from last week wa
s producing the X and Y motor pulleys... yet again based on random belts I pulled from printers. Th
ese were a bit larger than I expected, but Griffin was able to produce the correctly toothed pulleys for them with only one re-try. He would model the pulley and send me the file, and I'd run to the laser and cut it out, then bike over to his house to see if it worked. I think the plan worked great. They pulleys are pretty much perfect, and base
d on a comment on my last post I've opted to reverse my layer order so that the edges of the pulley are convex. This means the belt will be held tighter in the middle and due to variations in radius resulting in different RPM at the edges, it ought to stay on better too.

I've been reminded by two people now to talk about one of my improvisations on the machine.
Because I could not find a source for linear bearings that were both low friction AND cheap, I decided to scrap the designs that need "precision steel rod" and substitute my own low-cost alternative. In this case, I went to a local and small hardware store and poked things together. I found a meter of aluminum rod for less than $5 and a
foot of good copper tube for about $4. I was in luck, not only d
o these two things have a low coefficient of friction, they were cheap! I bought them and then sawed the rod in half and the tube into short sections the same length as the X and Y stages are wide. Now, the tube's outer diameter is not the same as the inside diameter that the makerbot was made to take... so I lazzored out an entirely new XY stage. The rod is M8, so it fit correctly. However, I made a silly error and made my cut exactly 1cm off from center, so one rod was too long and the other too short. As a result I had one rod that simply needed trimming to fit, and one that could never be augmented.
Quite the dilemma, or so I thought. Then I remembered that I have a laser cutter at hand. I simply made some hole-extenders from the endcap design and bolted them onto the inside. Turns out there is a lot of wasted space in the Makerbot Cupcake. Another triumph of frugality and improvised parts!

Next up, I finally discovered why my package from Digikey was taking so long... I had supplied the wrong address! The keys 9 and 6 are hard to accidentally interchange, but what can I say? I re-ordered and the package arrived last monday (yesterday as of writing). I gathered up everything I thought we would need and carried it all over to Griffin's to solder the last parts onto the boards. Great success! They're looking nice, and the only thing that has an issue is the big resistor on the motherboard. It's there to put a load on the PSU to get it to turn on (talk about an odd safety system). Sadly, we got a 5W .30ohm resistor... the machine needs a 5W 30ohm one. Whoops. We also have a 5W 3.0ohm resistor, so thi
s is comical. If only we could test it.

That brings me to the next item I want to talk about! I read this walkthrough on converting a nokia phone cable to a USB->TTL serial cable, and decided that that was the most cost effective way of getting the needed programming cable. I was able to get one of these cables for $3, shipped. That's a terrific deal. Or it would be, if I could make it work.
The cable declares itself to my computer, and USB probing makes me think that it is indeed working. However, in the step where I must probe the voltage on the Tx and Rx lines, I get a minute amount of power out of it. Not sure how to continue, so I just soldered the lines to a makeshift port anyway, though I am afraid to try to use it. Would rather not have to buy one.
If anyone knows what my issue there might be, let me know or I just might fry something.

Tomorrow I'll be building an extruder based on the PAXtruder, but with a NEMA-23 stepper as a drive. Ought to work, but I have not done any math to prove it. I'll also be making four more conventional gearmotor extruders, for the TEClub to use with our always-advancing Prolight Mill headcrab. It may be able to print up to six copies of something at the same time!
Lots to do, lots to do!

Sheesh, this is a very long post.
Thanks for reading!


  1. Based on the price and picture, I got the exact same cable from the same supplier - it was jing liu Item description was USB Data Cable for Nokia CA-42 6070 6120 6225 7360 5070 ,
    Item# 270442604597

    If it is the same cable, I can help you.
    There are three wires, Blue/Green, Orange, and Red.
    Blue/Green is TX, Orange is ground, and red is RX.

    I also took a razorknife and cut the molded plastic off the end, exposing the USB connector/board/chip thing. It's a tiny piece of standard circuit board with a COP-style epoxied in place chip and twelve solder pads. My probing determined:

    1 ?
    2 +5v
    3 RI
    4 RX
    5 ?
    6 GND
    7 DSR
    8 CD
    9 RTS?
    10 RTS?
    11 DTR
    12 TX (3.3v)

    Note that there seemed to be 2 RTS pads, and I was unable to determine CTS. I used python's serial module on the python command line to set and probe with a multimeter for the outputs, and probing with a small-valued resistor and hitting "enter" on a complex python print statement to determine the inputs.

    Also note that I haven't used it successfully yet, as I'm still having issues loading the bootloader into the chip that I have. It's a work in progress that has been interrupted to work on getting triffid's 5D firmware working on my original arduino.

  2. Hey, thanks for the comment.
    That confirms what I got from the pin numbers on the phone end of the cable.
    I decided to stop poking it with the multimeter and instead attached them to a header stand-in (I seem to not have a 6x1 .1 spaced female header), and I've been trying to program with it.
    I've gotten some assorted error messages, usualy syncing or "hardware does not respond" sorts of things.

  3. Unless you have the boot loader and fuses done already, you will not be able to program with this cable. The "bit banging" mode requires more wires than three. That's the reason that I decided to go ahead and take a razorknife to the molded end, to get access to more pins.

  4. I have done the bootloaders, and get all the right blinking LEDs too.